It appears you have not yet registered with our community. To register please click here.

Origin XT RPG Network Home







XT Project Introduction
Blah blah intro to this place. To be composed later.

AJAX QuickEdit released for 2.0


Jul 31 2006, 12:06 AM (Post #1)
Not Odd anymore
* * * * * * * * * *
Posts: 45,875
Cash: 1,915,578 / 1,817,041,051
Group: Administrator
Joined: 7/10/02 09:48 PM

5 Pages  1 2 3 > »  
Jul 31 2006, 12:08 AM (Post #2)
Peasant

Posts: 21
Cash: 4,599 / 0
Group: Newbie
Joined: 7/25/06 06:46 PM
awesome another great mod!
Post Options

Jul 31 2006, 04:08 AM (Post #3)
Not Odd anymore
* * * * * * * * * *
Posts: 45,875
Cash: 1,915,578 / 1,817,041,051
Group: Administrator
Joined: 7/10/02 09:48 PM
Thanks for your compliment ssmile.gif
Post Options

Jul 31 2006, 01:24 PM (Post #4)
Peasant

Posts: 22
Cash: 9,001 / 0
Group: Newbie
Joined: 7/30/06 05:17 PM
any chacnce for this to be made for 1.3? mainly the ajax code all the rest i am capable doing myself.
Post Options

Jul 31 2006, 06:13 PM (Post #5)
Not Odd anymore
* * * * * * * * * *
Posts: 45,875
Cash: 1,915,578 / 1,817,041,051
Group: Administrator
Joined: 7/10/02 09:48 PM
Read the other topic regarding the ajax code. You need it included in your pages. Otherwise it will work.
Post Options

Aug 2 2006, 10:53 AM (Post #6)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
are we set with sin edits regarding the Quick edit button ?

it works nicely by the way

cool MOD !

very fast

This post has been edited by NickTheGreek: Aug 2 2006, 10:58 AM
Post Options

Aug 2 2006, 01:03 PM (Post #7)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
i think the HTML guide is a little messy... i had to tide up he Topics.php line edits , the topics fle is not causing errors snow

but after doing skin edits i get java:void onthe edit button

FYI, i am also using ur AJAX preview mod and D2 QUICK EDIT

is there a problem using D2 and your own simultaneously ?
Post Options

Aug 2 2006, 01:11 PM (Post #8)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
anyway, i have made all edits u mention but when i click on the EDIT button nothing happens

ur preview MOD works fine, so java is not an issue
Post Options

Aug 2 2006, 07:01 PM (Post #9)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
latest update: your HTML needs to be revised a bit, line index is wrong because it is wrappaed... i made all edits to have this worek and it does now

but there is no upll down menu like here, just a yes/no selection

anbd when i accept using AJAX edit, the WHOLE SKIN HTML gets in the quick reply button

i will revert the edits now, but when u get online i can show u what i mean
Post Options

Aug 2 2006, 07:21 PM (Post #10)
Not Odd anymore
* * * * * * * * * *
Posts: 45,875
Cash: 1,915,578 / 1,817,041,051
Group: Administrator
Joined: 7/10/02 09:48 PM
QUOTE (NickTheGreek @ Aug 2 2006, 02:53 AM)
are we set with sin edits regarding the Quick edit button ?

it works nicely by the way

cool MOD !

very fast
*


What do you mean with sin edits?

Thanks for the compliment.
QUOTE (NickTheGreek @ Aug 2 2006, 05:03 AM)
i think the HTML guide is a little messy... i had to tide up he Topics.php line edits , the topics fle is not causing errors snow

but after doing skin edits i get java:void onthe edit button

FYI, i am also using ur AJAX preview mod and D2 QUICK EDIT

is there a problem using D2 and your own simultaneously ?
*


What do you mean the HTML guide is a little messy? My PHP editor randomly switches between spaces and tabs, so the aesthetics needs to be worked out by you guys. What errors were they causing?

What do you mean you get java:void on the edit button

D2 and my quick edit or preview mod? D2 & my preview mod are compatible, but D2 and my quick edit are not.
QUOTE (NickTheGreek @ Aug 2 2006, 05:11 AM)
anyway, i have made all edits u mention but when i click on the EDIT button nothing happens

ur preview MOD works fine, so java is not an issue
*


I think you didn't copy directly. Seriously, your board is too modded.

It's supposed to have a popup asking you if you want to quickedit. No drop down menu.
QUOTE (NickTheGreek @ Aug 2 2006, 11:01 AM)
latest update: your HTML needs to be revised a bit, line index is wrong because it is wrappaed... i made all edits to have this worek and it does now

but there is no upll down menu like here, just a yes/no selection

anbd when i accept using AJAX edit, the WHOLE SKIN HTML gets in the quick reply button

i will revert the edits now, but when u get online i can show u what i mean
*


>_< Come on, it worked on all my tests. How come it won't work on yours? What MODs do you have installed anyway?

My guarantee is that it will work on any unmodded board.

Plus (no offense, but) your english is essentially incomprehensible. I try to understand, but I am sure I am not understanding what you are trying to convey. Please show with examples in this case (what errors are produced, screenshots, etc)
Post Options

Aug 2 2006, 07:35 PM (Post #11)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
ok, i will do my best to make u understand the issue:

i have this working right now, come and edit using AJAX edit one of your posts: you will see that the whole HTML of the page gets parsed ! seriously, the whole skin HTML gets into the fast reply / quick edit box !
Post Options

Aug 2 2006, 07:39 PM (Post #12)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
and another comment, if you do not mind:

in your version of this MOD here in the site, when i click the edit button i get a drop down menu with options:

Quick edit / Normal edit

in the MOD you have released i get a centered dialog with the option ot use Quick Edit (Yes/No)

apart from that, you should check the HTML tutorial: all code boxes have text wrapped together instead of proper line breaks

this is a prt from it:

CODE
//----------------------------------------- // BEGIN Jinghao
Yan/Origin's AJAX QuickEdit MOD for IPB 2.0.x (visit
http://www.originxt.com for more info)
//----------------------------------------- else if
($ibforums->input['view'] == 'getrawpost') { // get first post from
topic $DB->query("select * from ibf_posts where
pid=".intval($ibforums->input['p'])); $row = $DB->fetch_row();
$input =
html_entity_decode($this->parser->unconvert($row['post'],
$this->forum['use_ibc'], $this->forum['use_html'])); $macros =
unserialize(stripslashes($ibforums->skin['_macro']));
//----------------------------------------- // Get the macros and
replace them //----------------------------------------- if ( is_array(
$macros ) ) { foreach( $macros as $i => $row ) { if
($row['macro_value'] != "") { $input = str_replace(
"<{".$row['macro_value']."}>", $row['macro_replace'], $input ); }
} } $input = str_replace( "<#IMG_DIR#>",
$ibforums->skin['_imagedir'], $input ); $input = str_replace(
"<#EMO_DIR#>", $ibforums->skin['_emodir'] , $input );
die($input); } //----------------------------------------- // END
Jinghao Yan/Origin's AJAX QuickEdit MOD for IPB 2.0.x
//-----------------------------------------


does it look like it will parse ?
Post Options

Aug 2 2006, 07:49 PM (Post #13)
Not Odd anymore
* * * * * * * * * *
Posts: 45,875
Cash: 1,915,578 / 1,817,041,051
Group: Administrator
Joined: 7/10/02 09:48 PM
Three things:

1. You did not follow my instructions. You were supposed to add the quickEdit function directly after the emo_pop function. NOT OUTSIDE THE COMMENTS. DIRECTlY AFTER.

2. The HTML comments inside your javascript (enclosing emo_pop() right now) must be delimited by //

3. You didn't do topics.php edits properly. Otherwise http://yourforum.gr/InvisionBoard/index.ph...t=33035&p=63719 should load the raw post.

By the way, I can't help you any further unless I get direct access to the source. PM me your FTP info.
Post Options

Aug 2 2006, 07:57 PM (Post #14)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
could you fix the HTML tutorial you provided ? i pointed you the issue with line breaks, the problem still stays or did u fix it ?

how could i do edits right if the code boxes u used in the HTML readme were wrong ?
Post Options

Aug 2 2006, 07:58 PM (Post #15)
Peasant

Posts: 40
Cash: 8,232 / 0
Group: Newbie
Joined: 7/27/06 12:05 AM
and, how do we make a drop down list with the 2 options : Quick Edit / Normal Edit

instead of the dialog box ?

it finally worked...

the tutorial on your other MOD was a lot more helpful ssmile.gif

one last thing : can u provide help on making 2 options as a drop down menu instead of the dialog box ?

there are still differences between ur version and the MOD i think

This post has been edited by NickTheGreek: Aug 2 2006, 08:25 PM
Post Options

5 Pages  1 2 3 > »